PoolParty Client Requirements

The PoolParty client has to meet the following requirements.

  • PoolParty works with the following browsers:
    • Chrome (25+)
    • Firefox (3.6+)
    • Microsoft Edge (41+)
  • PoolParty has been designed for a screen resolution of 1280x800 or higher. 
  • It is recommended to have a DSL connection to the internet, otherwise response times might be a bit slow.